
Unity 講習資料１ 
 

０．はじめに 

Unity 部門の講習を始めます。これから皆さんには、Unity というソフトを使ってゲ

ームを作ってもらいます。目標は、文化祭で自作のゲームを一本公開することです。 

さて、この講習資料についてですが、実際に Unity を動かしながら操作やコマンド、

用語などを覚えてもらうことを目的に書いています。が、まあ完璧に覚えるというの

は無理なので（自分も覚えてないです）、この資料を片手にゲームを作ってもらえれ

ばと思います。また、今はまだわからなくてもいい、本筋からそれる所は「飛ばして

ください」と書いてあります。そこは飛ばして、あとで戻ってきたり家で読んだりし

てください。 

※資料は Unity がインストールされていることを前提としています。 

 

１．Unity をはじめる 

Unity は、世界中のゲームクリエイターが使っているゲーム開発ツールです。「これを

使えば簡単にいろいろなゲームを作れる」と思ってくれて構いません。無料で使用で

きます。さっそく始めてみましょう。 

① デスクトップ上の「Unity Hub」のアイコンをダブルクリックして開いてくださ

い。するとこんな画面が出ると思います。 

 

Unity Hub は Unity 本体の管理をするソフトです。ここから Unity をインストー

ルしたり、プロジェクトを作ったりできます。 

プロジェクト：作るゲームそのもののデータをまとめたもの。 

 

② 新規作成ボタンを押してプロジェクト名に好きな名前を入れて（わかりやすいほ

うがいいです）、作成ボタンをクリックしてください。しばらく待つと Unity 本体

が起動します。 



 

 

③ 上の画面の説明をします。飛ばしてください。 

（０） そもそもこの画面は 

Unity Hub で新しくプロジェクトを作るとき、最初に設定ができる画面で

す。 

（１） テンプレート 

２D ゲームか３D ゲームか、あるいはその設定はどうかを選べます。 

２D：２D ゲームに適した設定のプロジェクトを作ります。 

３D：３D ゲームに適した設定のプロジェクトを作ります。 

３DWithExtras：PostProcessing なる機能を使える３D のプロジェクトを

作ります。使うとグラフィックがきれいにできるようです。 

HighDefinitionRP：とてもきれいなグラフィックの３D のプロジェクト

を作ります。HDRP とか ShaderGraph とかいう機能が使えるようです。 

UniversalProjectTemplate：いろんなところで使える３D のプロジェクト

を作ります。設定が簡単に変更できるらしいです。 

 

このうち下の三つは、パソコンに負荷がかかりすぎる上、そこまでハイレ

ベルなものを使う必要がないのでやめたほうがいいです。 

ということで、２D か３D を選びましょう。 

（２） プロジェクト名 

プロジェクトの名前を付けられます。今後も何度か書くつもりですが、名

前はわかりやすいものを付けたほうがいいです。「aaa」とかじゃ後になっ

て絶対に「なんだこれ」ってなります。 



（３） 保存先 

プロジェクトは当然 PC のどこかにデータの形で保存されるのですが、そ

の保存先を決められます。「…」ボタンから保存したい先のフォルダを選

びます。部の PC を使っている間はいじらないでください。 

（４） プロジェクトの作成 

右下の作成ボタンを押すと、いままでした設定に従ってプロジェクトが作

られます。そしてしばらく待つと（ここではプロジェクトの構造の作成や

プロジェクトの呼び出しが行われています）Unity 本体が新しいプロジェ

クトを開いて起動します。 

 飛ばしてください、の部分終わりです。 

 

２．シーンとオブジェクトとコンポーネント 

Unity を使う上で重要な概念、シーンとオブジェクト、コンポーネントについて説明

します。この先何度も使う用語なので、覚えてください。 

シーン：Unity が作り出した仮想空間のことです。日本語にすれば「舞台」「場面」。

このシーンにオブジェクトを配置することで、ゲームが成り立ちます。また、シーン

はプロジェクト内で複数制作でき、それぞれを転換することでゲームを作っていきま

す（タイトル画面、ホーム画面、プレイ画面などを別々のシーンで作り、転換してい

きます）。 

オブジェクト：「もの」のことです。しかし、それ自体では何も為さず（目には見え

ませんし、形もありません）、「コンポーネント」という情報、機能がつくことで、は

じめて役目をもちます。コンポーネントのくっつく場所、というのがより正確です。 

コンポーネント：オブジェクトにつく情報や機能のことです。オブジェクトはそれだ

けでは目には見えないし、動いたりしないし、何かにぶつかることもありません。し

かし、そのオブジェクトにコンポーネントを付けると、目に見えるようになり、動き

出し、何かにぶつかるようになります。コンポーネントは Unity に初めから設定され

ているものの他、自分で書いたプログラムもコンポーネントとして扱われます。 

 

３．画面の説明 

Unity の画面の説明をします。 



 

① ヒエラルキー 

シーンにあるオブジェクトを表示します。 

② シーン・ゲームビュー 

シーンビューとゲームビューの二つを見れます。 

シーンビューではシーンの状況を確認できます。 

ゲームビューでは、レンダリング（リアルに表示すること）後のシーンを確認で

きます。指定のカメラから見た景色が映されます。 

シーンビュー、ゲームビューの切り替えは左上のタブでできますが、実行および

実行停止時に自動で切り替わるので、必要はないでしょう。 

③ インスペクター 

選択しているオブジェクトについているコンポーネントを確認、編集できます。 

④ プロジェクト・コンソールビュー 

プロジェクトビューとコンソールビューの二つを見れます。 

プロジェクトビューでは外部ファイルなどの操作ができます。プロジェクトのフ

ォルダ内の Asset フォルダと同期しています。 

コンソールビューではバグの表示やデバッグログの表示を行います。 

左上のタブで変更できます。 

⑤ ツールバー 

いろんなことができます。 

 



４．オブジェクトの作成 

⓪ シーンには作成された時点で既にいくつかのオブジェクトが存在します。簡単に 

その説明をします。 

Main Camera：カメラです。ここから見える景色が最終的なゲームの視点になり 

ます。 

Directional Light：光源です。Unity は光の当たり方なども計算してくれます。な 

いと画面が暗くなります。 

 

オブジェクトを作ってみましょう。 

① ヒエラルキー上のどこかを右クリック or 左上の create をクリックし、3D 

Object>Sphere を選択します。するとシーンに球が作られます。インスペクター

にも作った球のコンポーネントが表示されます。 

 

このようにすると、オブジェクトを作れます。 

 

② 作れるものの説明をします。飛ばしてください。 

CreateEmpty：実体のないオブジェクトを作ります。ゲームの進行管理などに使

います。 

Cube：立方体を作ります。 

Sphere：球を作ります。 

Capsule：カプセル（昔の錠剤みたいな形）を作ります。 

Cylinder：円柱を作ります。 

Plate：厚さ０の直方体を作ります。床や壁に使用します。 

Quad：厚さ０の目に見えない直方体を作ります。画像を張り付けて使用します。 

Text,Regdoll,Terrain,Tree,WindZone,3DText：難易度が高かったりアセットスト

アの使用を前提としているのでやりません。気になった人は自分で調べて挑戦し



てみてください。 

２D Object：２D のオブジェクトを作ります。そのうちやります。 

Effect：エフェクトを作ったり制御できます。扱う予定はありませんがおもしろい

のでやってみることをおすすめします。 

Light：光源を作れます。 

Audio：音声にかかわるものを作ったりできます。 

UI：UI（入力や表示のこと）に関するものを作れます。（ボタンなど） 

Camera：カメラ（視点）を作ります。 

飛ばしてください、の部分終わりです。 

 

５．コンポーネントを付ける 

⓪ オブジェクトは作った時点ですでにいくつかのコンポーネントがついています。 

 簡単にその説明をします。 

 Transform：位置の情報。あとでやります。 

 Sphere(Mesh Filter),Mesh Renderer：どちらもオブジェクトの描画に関するもの 

です。 

 Sphere Collider：当たり判定です。 

 Default-Material：オブジェクトの材質や色の情報です。 

 

球に物理演算をさせるコンポーネントをつけて、重力をかけてみましょう。 

① 球を選択した状態で（シーンの球をクリックすると選択できます）インスペクタ

ーの一番下にある Add Component ボタンを押し、Physics＞Rigidbody を選択し

ます。これで球に Rigidbody コンポーネントが追加されました。 

 

Rigidbody 以外の様々なコンポーネントも Add Component ボタンから追加できま

す。 

Rigidbody：これがついたオブジェクトに物理演算をさせるということを意味する

コンポーネント。ここでいう物理演算とは、力を受けた時の挙動のほか、重力を

含みます。 



 

② シーン・ゲームビューの上の再生ボタン（▶）をクリックしてください。 

 

すると視点が変わり球が落ちるのが見えたと思います。

 

 

③ もう一度再生ボタンをクリックし、もとの画面に戻りましょう。球ももとの位置

に戻ります。 

再生ボタン：押すとゲームが実行されます。つまり、入力を受け付けたり、物理

演算を開始したりします。 

 

６．足場を作る 

球が落ちないように足場を作ります。 

① ヒエラルキー上で右クリックし、3D Object > Cube を選択します。すると球があ

った位置に立方体が出現します。重なっているだけで、球は消えていません。 



 

 

② インスペクターの上側の Transform の Position の Y を、０から－２にします。欄

をクリックしてキーボードで入力してください。

 

すると立方体の位置が変わりました。コンポーネントの数値もインスペクターか

ら編集することができます。 

Transform：オブジェクトの位置や大きさの情報を表すコンポーネント。 

Position：Transform コンポーネントのもつ情報の一つで、位置の情報。座標空間

上での座標を表す。 

座標空間：座標平面（数学でやります）の立体版。ある一点を基準とし、そこか

ら前、横、上方向にそれぞれどれだけ離れているかを表す。 

③ このままだと狭いので大きくします。Transform の Scale の X,Z をどちらも１０

にしてください。 

 

立方体が縦横に大きくなりました。 

Scale：Transform のもつ情報の一つで、大きさの情報。 

 



④ 再生ボタンを押して再生してみましょう。球が足場に落ちて止まったのがわかり

ます。 

 

 

７．動かせるようにする 

球を自分で動かせるようにします。 

① シーン上の球をクリックし、インスペクターから Add Component > New Script

を選択し、名前を Player とつけ、create and add を押します。 

 

スクリプト：プログラムのこと。よくわからない英語を書いてなんかが動く、と

いう一般的なイメージのプログラムのこと。Unity ではスクリプトもコンポーネン

トのひとつとして扱われます。 

 

② プロジェクトビュー（画面下）にできた Player と書かれたものをダブルクリック

します。 

 

しばらく待つと「Visual Studio」もしくは「Visual Studio Code」という別のソフ

トが起動します。 



 

「Visual Studio」：スクリプトを書くソフト。スクリプトはしょせん文字なので、

メモ帳でも書けるのですが、これにはプログラムを書くうえで便利な機能がつい

ています。Visual Studio Code も同じです。 

 

③ 以下のように打ち込んでみましょう。大文字と小文字の区別は正確に。

 

 

④ 右上にあるファイル（File）＞Player.cs の保存(save,セーブ) を選択し、保存し

ます。Ctrl キー＋S キーでも保存できます。保存しないと変更が反映されないの

で注意。 

 



 

 

⑤ シーンを再生して、→キーを押してみましょう。ボールが右側に動いていきまし

た。 

 

 

８．７の解説 

元から書いてあるやつ こっちは流し読みでいいです。 

１～３行目：Unity のコマンドを使用する、という定義。いじらないでください。 

５行目：Player というクラス（わかんなくていいです）の宣言。この中に書いたこと

がシーンに反映されると思ってください。いじらないでください。 

８～１１行目：このスクリプトが呼び出された最初の一回だけカッコ内の処理を実行

する、という意味。 



１４行目：毎フレームカッコ内の処理を実行する、という意味。 

フレーム：ゲームの処理時間の単位。初期設定では１フレーム＝0.0166…秒であり、

0.0166…秒に一回処理が行われます。 

７、１３行目：コメントアウトされた説明。「//」と打った後の文はプログラムに無視

されます。これをコメントアウトといいます。これでプログラムの説明を行ったり、

一時的に問題のあるプログラムを処理させなくしたりします。 

 

書き足したやつ こっちはちゃんと読んでください。 

if(~){…}：もし～なら…する、の意味。一番よくつかうプログラムで、基本中の基

本。～には真偽を判断できる文が書かれる。 

Input.GetKey(KeyCode.~)：～キーが押されているかいないかを返すプログラム。こ

の場合は RightArrow、つまり右矢印キーが押されているかどうか。 

GetComponent<Rigidbody>().AddForce(x,y,z);：球に力をかけるプログラム。x,y,z

はそれぞれ左右、上下、前後にどれだけ力をかけるかを表します。今回は 1f,0f,0f な

ので、右方向にのみ 1 だけ力がかかります。f についてはあとで説明します。また、

文の最後にある「;」（セミコロン）は、命令の最後に必ずつけなければいけない記号

です。 

以上より、このプログラムは「もし→キーが押されているなら、球に右方向に力をか

ける」という意味になります。 

 

９．もっと動かせるようにする 

右以外にも動かせるようにします。 

① 以下のように加筆して保存してください。コピー＆ペーストを使うと楽です。 



 

② 再生ボタンを押すと、押したキーの方向に球が動きます。 

 

１０． シーンの保存 

① このあたりでシーンを保存しましょう。保存はこまめに行わないと、PC が落ちた

ときに今までの作業が水の泡となってしまいます。今回は初めての保存なので、

ファイルに名前を付けてもらいます。右上の File→Save As を選択し、mainscene

と名付けて保存してください。 

② 上書き保存の方法は、プログラムと同じように File→Save もしくは Ctrl＋S キー

です。これからは保存の指示はしませんが、適宜保存をしてください。 

１１． 変数 

プログラムには「変数」という概念があります。その解説をします。 

変数とは、データを入れる箱です。その中には数値だったり文字だったり、Unity で

はオブジェクトなんかも入れられます。しかし、中に入れられるデータの種類は決ま

っており、数値を入れる箱に文字を入れることはできません。この中に入れられるデ

ータの種類は「型」と呼ばれます。 

変数にできることは主に①宣言、②代入、③参照の３つです。 

① 宣言 

まず初めに、「こんなデータが入れられるこんな名前の箱をつくります！」という

こと。変数は宣言しないと使えません。 



具体的には 

int A ; 

のように書きます。これは、int 型（整数を入れられる型）の変数 A を作る、とい

う意味です。 

② 代入 

宣言した変数のなかにデータを入れ、書き換えること。 

具体的には 

A = 2; 

のように書きます。ここでの「＝」は数学的な＝とは違い、左のデータを右の変

数に代入する、という意味です。そのため、 

A = 2; 

A = 3; 

のように書いても問題ありません。（このプログラムは、A の中身を２にした後、

３にする、という意味です。そのため、現在の A の値は３です。２というデータ

は消えます） 

また、宣言と代入は同時に行えます。 

int A = 3; 

と書けば初めから３が入った変数 A がつくれます。 

③ 参照 

変数は中身のデータと同じようにふるまいます。 

例えば、 

int A = 2; 

int B; 

B = A + 3; 

と書いたとき、B の値は５になります。 

 

１２． 変数を使う 

変数を使ってみましょう。 

① プログラムを以下のように書き換え、保存します。（背景が変わったのは気にしな

いでください） 



 

float：小数を扱う型。この型に代入する数値の最後には「f」がつきます。 

public：宣言の前に public とつけると、このスクリプトの外（別のスクリプトや

インスペクターなど）からの操作を受け付ける変数ができます。逆に、操作を受

け付けない変数は private と書きます。省略すると private になります。 

 

② 再生ボタンを押すと、先ほどより遅いスピードで球が動きます。 

これは与える力が１から Speed（ここでは 0.5）になったからです。 

 

③ Speed = 0.5f; 

を 

Speed = 10.0f; 

に書き換えてみましょう。 

すると、動く速度がとても速くなります。 

変数を使うメリットの一つは、このように書き換えが１回で済むところにありま

す。 

 

④ Speed =10.0f; 

を削除してみましょう。 

ここで球のコンポーネントを見ると、Player の下に Speed という欄ができていま



す。これを１００に書き換えてみましょう。 

 

球の動きがとても速くなりました。このように、public 変数は Unity エディター

上からも編集できます。 

 

⑤ Speed は 5 くらいに戻してください。 

 

１３． アイテムを作る 

このゲームはアイテムを集めるゲームにしようと思います。そのため、アイテムを作

ります。 

① 3D Object の Capsule を作ります。 

② Capsule の x 座標を２にします。

 

この時点では Capsule は空中に浮かぶ障害物です。 

③ 触ったら消えるようにします。Player スクリプトを以下のように加筆して保存し

てください。 



 

36 行目：このオブジェクトが何かと衝突したときにカッコ内の処理を実行し、ま

たその衝突判定（Collition）を Hit と名付ける、という意味。 

38 行目：GameObject 型の変数 obj を宣言し、Hit の（当たった）オブジェクト

を代入する、という意味。Hit.gameObject の「.」は「複数の情報をもつもののう

ち、これ」という感じの意味です。今後も出てきます。 

GameObject 型：オブジェクトを入れる型。 

39 行目：obj（当たったオブジェクト）のタグが Item ならカッコ内の処理を実

行。タグについてはあとで解説します。 

40 行目：obj を消滅させる、という意味。 

Destroy(オブジェクト)：オブジェクトをゲーム内から消すプログラム。 

 

④ このままだと動かないので、Unity でタグに関する編集をします。 

タグ：コンポーネントの一種で、オブジェクトの識別によく使われます。インス

ペクターの一番上から編集できます。 

 



最初は Item というタグはないので、Add Tag を押して追加します。 

 

＋を押して、Item と入力して save ボタンを押します。 

 

Item タグが追加されたので、Capsule のタグを Item に変更します。クリックでで

きます。 

 
 

⑤ 実行すると球が衝突したときにアイテムが消滅します。 

 

１４． アイテムの挙動を変更する 

このままだとアイテムに衝突したときに一瞬止まってしまいます。別にこれでもいい

のですが、プレイのスムーズさを考えて止まらないようにします。 

① Capsule の Capsule Collider にある Is Trigger にチェックをいれます。 

 

こうすると、球が衝突せずにすり抜けるようになります。実行すると、アイテム

が消えずに球をすり抜けているのがわかります。 



② プレイヤースクリプトを以下のように書き換え、保存してください。 

 

OnTriggerEnter は OnCollisionEnter の Is Trigger 版です。Is Trigger なオブジェ

クトに触れるとカッコ内の処理が実行されます。また、()の中身が Colli sion から

Collider に変更されていますが、Collision が衝突の情報を表すのに対し、Collider

はコライダーという当たり判定のコンポーネントを表します。（この辺は複雑なの

でいつか改めてやります） 

③ 実行すると、衝突時に速度を落とさずに消えるのが分かります。 

 

１５． オブジェクトのコピペと削除と命名 

アイテムが一個だとつまらないので、増やします。しかし、これと同じものを一から

作るのは面倒なので、便利な機能を使います。 

① コピペをします。 

ヒエラルキーから Capsule を右クリックし、copy を選択し、ヒエラルキー上で右

クリックし、paste を選択します。 

 

すると Capsule がもう一つできます。Position の X を２にするとわかりやすいで

す。 

② 別のコピペの方法を教えます。 

ヒエラルキーから Capsule を右クリックし、Duplicate を選択します。これだけで

もコピペができます。 

 

③ これでもいいのですが、もっと便利な方法があるので、そちらの方法で進めま



す。せっかく作ったオブジェクトですが、削除してください。ヒエラルキーから

Capsule(1)を右クリックし、Delete を選択します。これでオブジェクトが削除さ

れます。Capsule(2)も削除してください。Capsule は残しておいてください。 

 

④ さっきから Capsule と言っていますが分かりづらいので、名前を変えます。 

Capsule を右クリックし、Remene を選択して Item と名付けてください。 

 

 ついでに球の名前も Player に変えましょう。別の方法を教えます。 

球を選択した状態で、インスペクターの一番上の Sphere と書かれた部分を選択

し、Player に書き換えましょう。 

 

１６． プレハブとインスタンス化 

Unity にはプレハブという機能があります。これは、オブジェクトの設計図のような

もので、これを使ってスクリプトからオブジェクトを作ることができます。プレハブ

を使ってスクリプトからオブジェクトを作ることをインスタンス化といいます。 

① まずはプレハブを作ります。ヒエラルキーの Item をプロジェクトビューにドラッ

グアンドドロップします。 



 

すると、プロジェクトビューになんかができます。これがプレハブです。 

このプレハブは、もとにしたオブジェクト（ここでは Item）と同じデータを持っ

ています。 

② もとにした Item は削除しましょう。 

③ インスタンス化をつかさどるオブジェクトを作ります。ヒエラルキーを右クリッ

クし、Create empty を選択します。すると GameObject ができます。 

 
画面には何もできていないように見えますが、これは GameObject が実体を持っ

ていないからです。 

④ Add Component>New Script から GameController という名前でスクリプトを追

加します。 



 

⑤ 以下のように GameController を編集してください。 

 

８行目：Vector3 型の変数 ItemPosition を宣言します。 

Vector3：数値を三つ持つ変数の型。位置情報などにつかいます。 

１２行目：ItemPosition に Item を生成します。 

Instantiate(オブジェクト,位置,角度)：オブジェクトを生成する命令。（）の中身は

「,」（カンマ）で区切られていて、一つ目は作るオブジェクト、二つ目はオブジェ



クトを作る位置、三つ目は作るオブジェクトの向きです。

Quarternion.Euler(0,0,0)については今はいいです。角度がついていないことを表

します。 

⑥ このスクリプトを動かす準備をします。GameObject を選択し、ヒエラルキーか

ら Item にプレハブをドラッグアンドドロップします。また、ItemPosition の X の

値を２にします。 

 

⑦ 実行すると、Item が作られたのが分かります。当たるとちゃんと消滅します。 

 

 

１７． 配列と for 文 

作る Item の数を増やします。 

① 以下のように GameController スクリプトを編集してください。 



 

② ここで新しいことを教えます。 

一つ目は「配列」です。配列とは、同じ型の変数が連なったものです。 

宣言の際は int[] A;のように、型の後ろに[]をつけます。 

このように宣言された配列は、A[0],A[1]のように「変数名[数]」の形で一つの変

数として扱うことができます。数は 0 から順番に割り当てられます。例えば 

int[] Score; 

Score[0] = 50; 

Score[1] = 70; 

float Average = (Score[0] + Score[1]) / 2; 

とすると、変数 Average には 60 が入ります。 

また、配列は「いくつの変数を連ねるか」という値を持ちます。これを配列の長

さといいます。配列は長さを指定しないと使えません（そのため上の Score の例

は、厳密にいうと正しくありません）。今回は public にしたので、Unity エディタ

ー上から長さや数値を指定します。長さは「配列名.Length」で取得できます。 

 

二つ目は for 文です。この文は 

for(int i = 0;i < ～;i++){ 

  中身 



} 

の形で使われ、中身の処理を～回繰り返す、という意味です。 

具体的にいうと 

変数 i を宣言し（int i = 0;）、もし i の値が～未満なら（i < ~;）(～は数値)、中身

の処理を実行し、i に１を足し（i++） 

この時点でもし i の値が～未満なら中身の処理を実行し i に１を足し…… 

という意味です。 

また、{}内では変数 i を使うことができます。i は一回目の処理では 0、二回目の

処理では 1、三回目の処理では 3、と、１ずつ増えていきます。 

 

以上を踏まえると、このプログラムの意味は、ItemPosition の長さ回、

ItemPosition[0],ItemPosition[1],ItemPosition[2]……の位置に Item を配置する、

という意味になります。 

 

③ このままでは動かないので、Unity から編集をかけます。GameObject の

Gamecontroller の ItemPosition の左の三角形を押して、size を 5 に変更してくだ

さい。これが配列の長さです。すると Element0 とかが出てくると思うので、以下

のように入力してください。 

 

④ 実行すると Item が５つそれぞれ指定した位置にできます。 



 

１８． 乱数 

ステージが毎回変わるようにします。 

① GameController を以下のように加筆してください。 

 

new：Vector3 型の変数に値を代入するには、position = new Vector3(x,y,z);のよ

うに、new を付けなければいけません。 

Random.Range(-5,5)：－５から５までの値をランダムに出力してくれます。 

② 実行すると、そのたびごとに Item の位置が変わるようになりました。 

 

１９． UI 

ゲームらしくするため、アイテムがあと何個あるかを表示するようにしましょう。 

① GameController を以下のように加筆してください。 

 



void OnGUI(){}：内部で GUI に関する命令を扱える、という意味。GUI とは UI

の一種で、まあ文字やボタンと考えてください。詳しいことは調べてください。 

 

GameObject.FindGameObjectsWithTag(“Item”)：Item というタグが付いている

オブジェクトを配列で取得する命令。この文は Item というタグのついたオブジェ

クトがすべて入った配列として扱えます。.Length は配列の長さを表すので、変数

Count には Item というタグがついたオブジェクトの数が入ります。 

 

GUI.TextField(new Rect(x,y,width,height),”text”);：画面に文字を表示する命令。

Rect は長方形という意味で、点(x,y)を起点に横 width、縦 height の長方形範囲を

表します。その範囲に、text 部分に書かれたことが書かれます。今回はテキスト

が+でつながれていますが、これでも ok です。 

 

Count.ToString();：int 型変数 Count を string 型に変換する、という意味。変数

Count は、このままでは文字として扱えないので、こんなことをする必要があり

ます。 

 

以上より、この文は「画面左上に Item の残っている数を「残り～個」と表示す

る」という意味です。 

② 実行すると、左上に Item の残った数が表示されます。Item をとると数が１減り

ます。 

 

２０． マテリアル 

見た目がぱっとしないので、オブジェクトの色を変更します。 

① プロジェクトビュー上で右クリックし、Create>Material を選択します。 



 

作成時に名前の入力ができるようになるので PlayerMaterial と名付けましょう。 

Material はオブジェクトの描画にかかわるコンポーネントで、色や質感を変更で

きます。 

② インスペクターの Main Maps から Albedo の右の四角を選択します。すると色を

選べる画面が現れるので、好きな色に変更してみましょう。 

 

③ プロジェクトビューの PlayerMaterial をシーンの Player にドラッグアンドドロッ

プします。すると Player の色が変わります。これは Player に PlayerMaterial が適

応されたからです。 



 

④ 同様にして ItemMaterial を作成し、色を変更しましょう。 

 

⑤ Item のプレハブを選択し、インスペクターの一番下の Add Component の横に

ItemMaterial をドラッグアンドドロップしましょう。すると DefaultMaterial が

ItemMaterial に置き換わります。 

 
⑥ お好みで足場の色も変えましょう。 

２１． シーン作成 

ゲームの始まりと終わりを作りましょう。最初に言ったっきりだったシーン機能を使

います。 

① 今のシーンを保存してください。 



② 画面左上の File>New Scene を押してください。 

 

するとシーンからオブジェクトがなくなりました。これはデータが消えたわけで

はなく、新しいシーンになったからです。 

③ File>Save As をクリックし、保存先に Scenes を選択します。ファイル名を

titlescene にして保存ボタンを押します。 

 

④ プロジェクトビューの Scenes を選択すると mainscene,titlescene,SampleScene の

三つがあるのがわかります。mainscene を選択すると、先ほどまで編集していた

シーンへ戻ることができます。 

 

⑤ このゲームのタイトルを表示させます。OnGUI でもいいのですが、別の方法を使



います。 

ヒエラルキーで右クリックして、UI>Text を選択します。 

 

すると、Canvas、Text、EventSystem が作られます。 

 

Text が文字で、Canvas はそれを映し出すスクリーンだと思ってください。また、

Text は Canvas の子オブジェクトです。子オブジェクトは、親であるオブジェク

トから様々な影響を受けるようになります（座標など）。詳しいことは後でやりま

す。 

EventSystem はボタンなどの入力を感知するために必要なオブジェクトです。い

じる必要はありません。 

⑥ Text のコンポーネントの Rect Transform,Text,Font Size を以下のように変えてく

ださい。PosX,Y,Z は中心の座標、Width,Height は大きさ、Text は書かれる内

容、Font Size は字の大きさを表します。 



 

 

⑦ 実行すると「玉転がしゲーム」と書かれているのが分かります。

 

 



２２． シーン遷移 

実行中にシーンを変更できるようにします。 

① UI>Button からボタンオブジェクトを作ります。 

② Button の Rect Transform コンポーネントと子オブジェクトの Text の Text を編

集します。 

 
③ 実行するとボタンが表示されているのが分かります。しかし、押しても反応しま

せん。 

 

④ 押すと mainscene に移動するようにします。Button に Add Component>New 

Script から ButtonScript という名前でスクリプトを追加し、以下のように編集し

ます。４行目にも追加されている命令があるので注意してください。また、

OnClick には public がついていることにも注意してください。 



 

４行目：シーンに関する命令を書くときに必要な記述です。 

OnClick（）のようなものを「メソッド」といいます。Update や OnTriggerEnter

２D などもメソッドの一種ですが、これらは特別な意味をもち、特定の時に呼び

出されます。Onclick は特別な意味を持たないので、このままだと呼び出される事

無く終わってしまいますが、あとからボタンが押されたときに呼び出されるよう

にします。くわしいことはいつかやります。 

SceneManager.LoadScene(シーン名);：カッコ内のシーンに移動できます。 

 

⑤ Button の Button コンポーネントの一番下にある On Click の+マークをクリック

します。 



 

⑥ None となっているところにヒエラルキーの Button をドラッグアンドドロップし

ます。 

 

⑦ No Function となっているところを選択し、Button Script>OnClick()をクリック

します。 

 

これで、ボタンが押されると ButtonScript の OnClick 内の処理が実行されるよう



になりました。 

⑧ File>Build Settings を開きます。 

 

⑨ Scenes in Build にプロジェクトビューから titlescene と mainscene をドラッグア

ンドドロップします。 

 

これをしないとシーンを移動することができません。 

⑩ 実行してボタンを押すと、シーンが変わりました。 

２３． ゲームを終了させるシーンを作る 

はじめのシーンを作ったので終わりのシーンも作りましょう。 



① 現在のシーンを保存し、File>New Scene でシーンを作り、Save As から endscene

という名前で保存します。 

② 以下のようになるように、Text と Button を作って配置してください。位置はだ

いたいで構いません。 

 

③ もう一度、と書かれた方に Return という名前でスクリプトを追加して、以下のよ

うに編集します。 

 

④ ボタンが押されるとこのスクリプトが実行されるようにします。 



 

⑤ File>Build Settings からこのシーンを Scenes in Build に入れます。 

 

⑥ 実行すると、もう一度ボタンが押されるとタイトルに移動するのが分かります。 

 

２４． ゲームの終了 

終わるボタンを押すとゲームが終了するようにしましょう。 

① 終わるボタンに Quit という名前のスクリプトを追加し、以下のように編集しまし

ょう。 

 

#if は if(){}とだいたい同じと考えてください。#if UNITY_EDITOR で、unity エ

ディターで実行されているなら、という意味です。 

UnityEditor.…… = false は、実行状態でなくす、という意味です。再生ボタンを

押したときと同じです。 

#else は、#if と同時に使われ、そうでないなら、という意味になります。この場

合、unity エディター以外で実行されているなら、という意味です。 

Application.Quit();はアプリを終了する、という意味です。ウィンドウ右上の×を



押したときと同じです。 

 

以上より、このスクリプトは「Unity エディター上で実行されているなら実行状態

でなくし、それ以外で実行されているならアプリを終了する」という意味になり

ます。Unity エディター以外で実行することがあるのかよ、と思うかもしれません

が、ゲームが完成したときに実行するのは PC やスマホや switch です 

② ボタンが押されたときにこのスクリプトが実行されるようにします。 

 

③ 実行して終わるボタンを押すと、実行状態が解除されます。 

 

２５． シーン遷移 

メインシーンでアイテムをすべて取ったらエンドシーンに移動するようにします。 

① 現在のシーンを保存して、mainscene に移動してください。 

② GameController スクリプトを以下のように編集します。 

４行目の追加と、Count = ～の位置の変更を忘れないで下さい。 



 

24 行目：「＝」は代入を意味しましたが、「＝＝」は左辺と右辺が同じかを判断す

る条件式となります。if(Count ==0)で「Count が０なら」の意味です 

③ 実行すると、アイテムをすべて取ったときに endscene に移動します。 

２６． クリアできないことをなくす  

このままだと、Player が足場から落ちるとクリアできないままになってしまいます。 

そのため、足場から落ちないようにします。 

① Player スクリプトを以下のように編集します。 



 

transform.position：Transform コンポーネントの position の情報。 

transform.position.x：Transform コンポーネントの position の情報のうち X の数

値。 

transform.position.x > 5：>は数学的な意味どおり、左辺のほうが大きいことを判

断する条件式です。if の中で「X 座標が 5 より大きいなら」という意味になりま

す。 

以上から、X 座標が 5 以上なら X 座標を５にする、というような命令です。 

なお、transform.position.x = 5;とは書けません。 

２７． 背景の変更 

背景を変更します。 

① Main Camera を選択します。 

② Clear Frags を Sky Box から Solid Color に変更します。 

③ Background で好きな色に変更します。 

 



④ 実行すると、背景が変わります。 

 

⑤ ほかの二つのシーンの背景も変更しましょう。 

２８． ビルド 

ゲームをアプリケーションにします。 

① File>Build Setting から順番が以下のようになっていることを確認します。なって

いなければドラッグで順番を変更してください。

 

 

② Build を選択します。 

 

③ 実行ファイルを作る位置を聞かれるので、右クリック>新規作成>フォルダーで

EXE という名前のフォルダを作り、それを選択します。 



 

④ しばらく待ちます。 

⑤ ファイルが完成するので、その中の 「名前.exe」というものを実行します。 

⑥ 先ほどまで作っていたゲームが遊べます。 

⑦ これにてゲームの完成です！ 

 

これでゲームの完成です。お疲れさまでした。次回からは２D ゲームの作り方をやってい

きます。 


